kali linux 安装CobaltStrike-4.4并且在windows11下上线

Kali linux 安装CobaltStr4.4 报错怎么办

安装最新版本kali linux ,在上面运行CobaltStr4.4发现报错

└─# ./teamserver 192.168.229.130 admin123
[*] Will use existing X509 certificate and keystore (for SSL)
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=on -Dswing.aatext=true
Exception in thread "main" java.lang.UnsupportedClassVersionError: hook has been compiled by a more recent version of the Java Runtime (class file version 58.0), this version of the Java Runtime only recognizes class file versions up to 55.0
at java.base/java.lang.ClassLoader.defineClass1(Native Method)
at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1017)
at java.base/java.security.SecureClassLoader.defineClass(SecureClassLoader.java:174)
at java.base/jdk.internal.loader.BuiltinClassLoader.defineClass(BuiltinClassLoader.java:800)
at java.base/jdk.internal.loader.BuiltinClassLoader.findClassOnClassPathOrNull(BuiltinClassLoader.java:698)
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClassOrNull(BuiltinClassLoader.java:621)
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:579)
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
at java.instrument/sun.instrument.InstrumentationImpl.loadClassAndStartAgent(InstrumentationImpl.java:431)
at java.instrument/sun.instrument.InstrumentationImpl.loadClassAndCallPremain(InstrumentationImpl.java:525)
*** java.lang.instrument ASSERTION FAILED ***: "result" with message agent load/premain call failed at ./src/java.instrument/share/native/libinstrument/JPLISAgent.c line: 422
FATAL ERROR in native method: processing of -javaagent failed, processJavaStart failed
./teamserver: line 50: 3307 Aborted java -XX:ParallelGCThreads=4 -Dcobaltstrike.server_port=50050 -Djavax.net.ssl.keyStore=./cobaltstrike.store -Djavax.net.ssl.keyStorePassword=123456 -server -XX:+AggressiveHeap -XX:+UseParallelGC -javaagent:hook.jar -classpath ./cobaltstrike.jar server.TeamServer $*

kali linux 安装CobaltStrike-4.4并且在windows11下上线

查看版本发现是11.0.16

kali linux 安装CobaltStrike-4.4并且在windows11下上线

查看资料发现要对jdk版本进行升级

安装JDK17

apt install openjdk-17-jdk

apt install openjdk-17-jdk-headless

update-alternatives --config java   #选择java 版本

查看Java 版本

kali linux 安装CobaltStrike-4.4并且在windows11下上线

再次运行./teamserver

kali linux 安装CobaltStrike-4.4并且在windows11下上线

运行客户端

kali linux 安装CobaltStrike-4.4并且在windows11下上线

生成payload在Windows11下运行

新建一个监听

kali linux 安装CobaltStrike-4.4并且在windows11下上线

kali linux 安装CobaltStrike-4.4并且在windows11下上线

监听创建成功

kali linux 安装CobaltStrike-4.4并且在windows11下上线

生成一个后门

kali linux 安装CobaltStrike-4.4并且在windows11下上线

kali linux 安装CobaltStrike-4.4并且在windows11下上线

会生成一个artifact.exe 文件,复制artifact.exe文件到测试机器上面 双击运行

kali linux 安装CobaltStrike-4.4并且在windows11下上线

可以看到已经上线成功了

kali linux 安装CobaltStrike-4.4并且在windows11下上线

发表评论

相关文章